Testnet Push Announcement

Hey all, sorry for the instability. We found and fixed a couple issues. Please reply here if you continue to have any issues and we will take a look.

User transactions are overwhelmed by BlockMetadata transactions which make dev and debug difficult.
There are about 2M txs, maybe only 1% is user txs.

3 Likes

Hi Brett,

Thanks for the update. It is work in progress so instability part of the game. Could you shed some light on the BlockMetaData transactions? Are they part of a performance test or something?
If so I am happy to see the TPS that is already being achieved. It beats the crap out of any public blockchain.

So, of all 8000000 transactions only about 800 are p2p or mint transactions. I guess there is some testing going on.

I couldn’t make any transaction,send or receive,unlike before with my ‘KedilLibrary’ a LibraVista wallet by Tokenclub.

How come it all got so messed up all of a sudden, we have being doing better but till after this update stage…

I’m trying to make transactions again after the testnet update but I receive Rejected with message “submit txn rejected”. I have compared my transactions to others that have been successful and I have all the data serialized correctly, so the problem must be the signing. I know the salt has changed so what is the salt that should be used? I have tried the “RawTransaction::libra_types::transaction@@$$LIBRA$$@@” that was mentioned in this thread but that didnt work. Is that correct? @QuincySx ? Or is there something else I did not see?

Ok, I think I got it. That salt is correct, the thing I missed was the deprecation of Program payload in a transaction and I need to use the Script instead. Now the transactions are working :slight_smile:

If you provide more detail, maybe I can help you.

I spent a lot of time to figure out, and you really safe my life.
Just curious where to find this? I looked around in libra source code and didn’t find it.

The faucet service is abnormal since 7 hours ago.

Faucet service is not working like it should

Faucet service is not working since yesterday.

Yes. For testing, you can try: http://explorer.moveonlibra.com/faucet

I have tried http://explorer.moveonlibra.com/faucet, why cannot be mint more than 0.1 Libra?

we provide an an easy to use rest api endpoint for the faucet (up to 100 Libs) per time here https://libexplorer.com/apis#faucet

The Testnet issues are being addressed as we speak…however we need keep focus and pace on key objectives and these directed efforts will give us the desired out put on the target on hand…our attention is to see how we go live from Testnet stage…That is what is key to know now.

2ndly we shall have to address the 1st 5 project and assist them integrate while the Calibra Team address main net internal issues…please let us stand by with results coming from the boot camp…Phase 2 has a new approach and I hope you all are catching and getting abreast of the new directions.

Because the testnet faucet service is unstable, we provoid an additional faucet api mint_mol . For example,

http://apitest.moveonlibra.com/v1/transactions/mint_mol?receiver_account_address=0000000000000000000000000000000000000000000000000000000000123456&number_of_micro_libra=1

Max support value is 1000_000_000 micro_libra = 1000 libra.

The original mint api is also available. when faucet service is down, it will fallback to mint_mol.

http://apitest.moveonlibra.com/v1/transactions/mint?receiver_account_address=0000000000000000000000000000000000000000000000000000000000123456&number_of_micro_libra=1

1 Like

Faucet down for 2 days. Having pseudo faucets is not a solution as they will run out of funds. Is anyone addressing this?

It appears the faucet was having some sporadic issues. i’ve restarted it and it should be stable now. Can you give it and try and lmk if you continue to have any issues? I’m investigating how we can better monitor for failed transactions.

2 Likes

Working again. Thanks