Minting in a local network

I’m running a 4 node network via docker in my dev machine. I used the client to connect to the instance via faucet_key for dev i.e. mint.key in terraform/validator-sets/dev but the client shows error

$ target/debug/client --host localhost --port 8000 --validator_set_file terraform/validator-sets/dev/trusted_peers.config.toml -m terraform/validator-sets/dev/mint.key

Error: Custom { kind: Other, error: “failed to fill whole buffer” }

I tried to build a mint node and bring it up via docker as well. It builds file but shows the same error when running the built image.

How do we mint within local instance of libra?

This doesn’t look like a minting problem.

How did you build the docker images for the validators?
Are validators and client built from the save version?

If you want something that’s known to be stable, it’s better to build and run from testnet branch and not master.

Currently I’m building off the master branch using the scripts in docker directory. Both validator and client are built of the same version. I will try to build from the testnet branch. Thanks for your suggestion.