3 Libra Nodes Local Network Setup But Unable to Mint

I have created and run a 3 node network in my local machine using the following. For e.g. for the first node:
cargo run -p config-builder validator
-a “/ip4/0.0.0.0/tcp/53700”
-b “/ip4/0.0.0.0/tcp/53700”
-d /root/libra/temp0
-i 0
-l “/ip4/0.0.0.0/tcp/53700”
-n 3
-o /root/libra/temp0
-s 50e53de2ca2006b933a4053cf4766c20ff773570e4af2d9d6ebca5ef02a49840

Followed by to launch the node :
cargo run -p libra-node – -f temp0/node.config.toml

Next, I created the faucet mint key:
cargo run -p config-builder faucet -o temp -s 50e53de2ca2006b933a4053cf4766c20ff773570e4af2d9d6ebca5ef02a49840 -n 3

And finally, I launched the client to connect to the network:
cargo run -p cli – -u http://localhost:53800 -m “temp/mint.key” --waypoint 0:d3cc98dbbbf2de595b3dff00376661583398c7b3ae61a8b8748e551e81d8c557

When trying to mint LBR to the account created, nothing happens when using ‘mint’.
when using ‘mintb’. Transaction timeout after showing waiting for …

Am I missing something? I quite sure I haved loaded the keyfile for the faucet account.

Take a look at our local docker setup: https://github.com/libra/libra/blob/master/docker/README.md

This should guide you through how to setup a local system.

Looking at your command, it is unclear what is hosted at 53800.

1 Like

hi. thanks for the reply. one of the validator node RPC port is exposed via 53800. I have looked through the local docker setup. It is using a faucet service to mint coins same as testnet.

However, I am trying to use a local faucet account to mint. Which is what libra-swarm is doing.

I realized my transactions failed with
[ERROR] Error minting coins: Transaction submission failed with error: JsonRpcError { code: -32010, message: "Server error: Mempool submission error: “Failed to update gas price to 0"”, data: None }

I am still exploring as to why this error occurs. I appreciate any insights and help.

to those who are looking for the answer. I did a workaround by using configs from libra-swarm instead to launch my libra-nodes. It worked, so I guess the issue is my setup via config builder. most likely i have configured the nodes wrongly.

Can you share the right way in detail about how to set up a local network with 3 libra nodes? I am looking for the method of setting up a network that consists of 4 validators. Many methods are outdated and invalid. Thanks for sharing!

Check the rust package ‘libra-swarm’. I did the following:

$ cargo run -p libra-swarm – -s -n 3

After running above command, you should see temp folder with configs in them. You can stop the process, and run the 3 separate processes with the following commands.

cargo run -p libra-node -- -f temp/0/node.config.toml cargo run -p libra-node – -f temp/1/node.config.toml
$ cargo run -p libra-node – -f temp/2/node.config.toml

You can run them in separate machines in the same network. But make sure you update the IP addresses. I updated the configs with public IPs I got from AWS.
I changed the seed address in all other node except node 0
I changed the broadcast address in each node respectively to correct IP address

Check the README in the source. Usually the steps there are more updated.